hsfl.net
当前位置:首页 >> 如何在uBuntu 12.04上安装Qt 4.8.4%Linux >>

如何在uBuntu 12.04上安装Qt 4.8.4%Linux

按照开发手册上安装好就可以了,但有个地方要注意一下: 12.04不能用root登录了,只能在终端上用命令操作,在root账户下添加的环境变量在一般的账户下不能用,但运行的Qt程序在一般的账户下运行的,这就导致了交叉编译设计好的应用程序时,找不...

官方只提供最近版本的直安装包,所以你只能下载源代码,进行编译,然后配置QT create。。 编译不懂可以看readme,里面是最简单的配置。 目测,没裁剪要几个小时编译

你是要开发嵌入式程序还是x11程序,两种环境都可通过编译Qt源码来安装,从网址 http://download.qt.io/archive/qt/ 可以下载各种版本的Qt源码,在ubuntu中解压,打开终端,进入解压后目录,敲入下面命令配置嵌入式版本的Qt(实际上是生成相应的ma...

官方只提供最近版本的直安装包,所以你只能下载源代码,进行编译,然后配置QT create。。 编译不懂可以看readme,里面是最简单的配置。 目测,没裁剪要几个小时编译

按照开发手册上安装好就可以了,但有个地方要注意一下: 12.04不能用root登录了,只能在终端上用命令操作,在root账户下添加的环境变量在一般的账户下不能用,但运行的Qt程序在一般的账户下运行的,这就导致了交叉编译设计好的应用程序时,找不...

记录下在CentOS下安装qt4.8的过程: (最好是在英文系统语言环境下安装,中文可能会出现无法正确中文字体) 1. 安装必需的环境 安装gcc和g++: [root@localhost local]# yum install gcc [root@localhost local]# yum install gcc-c++ 安装Xlib...

qtcreator中选项设置中可以选择你操作系统中安装的qt版本, 如果你实在不想安装其他版本,就去官网下载一个单独的qtcreator安装包

wiznote : 依赖: libqtcore4 (>= 4:4.8.4) 但是 4:4.8.2+dfsg-2ubuntu1~precise1~ppa6 正要被安装。 这个提示需要使用4.8.4版本以上的qt组件,但是安装的版本是4.8.2. 可以考虑先安装一下qt的组件:sudo apt-get install libqt4-dev。 在Ubuntu14...

tar zxvf qt-everywhere-opensource-src-4.8.4.tar.gz 进入解压后文件目录,执行配置 root@emouse:~/study# cd qt-everywhere-opensource-src-4.8.4/ root@emouse:~/study/qt-everywhere-opensource-src-4.8.4# ./configure 修改配置文件

新立德里先卸载掉libqtcore4这个包(一般会有驱动,vlc,vbox等依赖,如果依赖过多的话自己决定) 然后安装libqt-core4这个包

网站首页 | 网站地图
All rights reserved Powered by www.hsfl.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com