hsfl.net
当前位置:首页 >> python中我用pyinstAllEr打包的ExE文件打不开,报... >>

python中我用pyinstAllEr打包的ExE文件打不开,报...

这是因为默认安装的Pyinstaller是3.31版本 不支持最新出的Python3.7 可以安装pyinstaller 3.4版本 支持Python3.7 pip install https://github.com/pyinstaller/pyinstaller/archive/develop.tar.gz

打包有错误,具体看build文件下的warn***.txt文档,里面详细记载了错误的原因。一般都是库丢失。 不要下拉双击执行,可以在控制台下执行,看看报错内容。 注意:打包时,要让其找到对应的各个lib的路径,就可以自动找到对应的lib,打包进去了。

1、安装PyInstaller 3.0 (1)下载:https://pypi.Python.org/pypi/PyInstaller/3.0,2015-10-04更新;【PyInstaller-3.0.tar.gz】 (2)解压文件:【D:\PyInstaller3.0】; (3)命令提示符进入到PyInstaller3.0文件夹内,输入命令:python set...

1、安装PyInstaller 3.0 (1)下载:https://pypi.Python.org/pypi/PyInstaller/3.0,2015-10-04更新;【PyInstaller-3.0.tar.gz】 (2)解压文件:【D:\PyInstaller3.0】; (3)命令提示符进入到PyInstaller3.0文件夹内,输入命令:python set...

不用看错误信息都基本上可以知道,你打包时候肯定缺东西了。 比如有一个aaa.py文件,你需要打包,要 pyinstaller -F aaa.py 这样生成之后,其实不管你有没有漏掉什么库都可以打包成功,不过要善于从提示中发现问题,他会提示你需要什么库,然后...

因为依赖的包没有打包进去

自己写一个hello world试一下。如果可以打包运行,那就是你自己的代码有问题。

你的python多少?打包我只认准cx_freeze 安装cx_freeze 地址:http://www.lfd.uci.edu/~gohlke/pythonlibs/#cx_freeze 建立setup.py: import sys from cx_Freeze import setup, Executable base = None executables = [ Executable('打包的文件...

一、下载pyinstaller 我使用的版本为PyInstaller-2.1,支持python版本2.3-2.7,点击这里下载。 二、安装pyinstaller 下载完成后,解压即可。我的解压目录为D:\Python27\PyInstaller-2.1\ 三、使用pyinstaller打包.py成.exe应用程序 1.注意使用前...

将模块的绝对路径添加到Python搜索路径中就可以了 import sysprint(sys.path) #显示python搜索库的路径sys.path.append('')import numpy #然后这样就可以正常搜索到python2.6下的库

网站首页 | 网站地图
All rights reserved Powered by www.hsfl.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com