hsfl.net
当前位置:首页 >> spring和hiBErnAtE3.6.10兼容最好的版本是哪个 >>

spring和hiBErnAtE3.6.10兼容最好的版本是哪个

spring最新的4.2.3版,各版都兼容.

搭配这种问题一般都是最高版本spring配置hibernate,spring3或者4对应hibernate3或者4,每个版本代码和配置相差无几,给你个源代码的例子吧,望采纳http://pan.baidu.com/s/1dDezJdJ 密码: hhbq

spring4+hibernate4比较好。 老项目用的应该是spring2.x+hibernate3

看jar包里的信息 1、Spring的版本信息查看 Spring.jar\META-INF\MANIFEST.MF,文件内容如下: Manifest-Version: 1.0Ant-Version: Apache Ant 1.6.5Created-By: 1.5.0_12-b04 (Sun Microsystems Inc.)Implementation-Title: Spring FrameworkImp

用最新的就好

我用spring3.2, hibernate 4.15, asm3.3,cglib2.1没问题啊

把jar包粘贴到你项目的lib里就行了,如果还是引用不成功,右键点jar包,选Build Path -> Configure Build Path 弹出的窗口里选Libraries选项卡里面的Add JARs添加 哪些必备要看你的项目里用到多少spring的功能,你可以全都不加,等到控制台报Cla...

HibernateTemplate是hibernate模板类.你需要把dataSource注入给sessionFactory然后把sessionFactory注入给HibernateTemplate org.hibernate.dialect.MySqlDialect true true com/etoak/bean/User.hbm.xml

大版本一致的就可以兼容的 不一致往往是不行的

最后都是要用新版的.. 3.3等老版的资料都以XML配置为主, 新版spring已经转为用java标注进行配置了。 注意到这个区别后,老版的经验也可以用在新版上。

网站首页 | 网站地图
All rights reserved Powered by www.hsfl.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com